INDEX ------------------- DF ------------------- WF ------------------- EF ------------------- FSW ------------------- OTHER ------------------- Memorials ------------------- NFC

Forums IndexDiscussion ForumWorkshop Forum  Events ForumFor Sale & Wanted ForumOther Model ForumsMemorials ForumNon-Fiat Content
 

Go Back   Xweb Forums > Workshop Forum

Workshop Forum "X1/9 Tech": Shop talk, repairs, mods, specs, info, how-to advice

Closed Thread
 
Thread Tools Display Modes
  #1  
Old May 6 2012, 5:28 am
Carl W Carl W is offline
Daily Driver
 
Join Date: Jul 2009
Location: Kansas City Kansas
Tail light Problem After Body Work

Since getting my X back after rear body work, I have tail light/brake light issues. There are two vertically placed bulbs in the tail light assembly. When I hit the brakes, The top bulb lights on one side, the bottom bulb on the other. Vice verse when the tail lights are turned on. The body guy obviously switched something on re-assembly. What's the most obvious solution? Thanks in advance.
  #2  
Old May 6 2012, 5:52 am
Black-Tooth's Avatar
Black-Tooth Black-Tooth is offline
Tony Natoli
 
Join Date: Jan 2008
Location: Santa Clarita California
You have the answer Carl...

I believe the LEFT side is correct...

Pull both assemblies and STARE and COMPARE. Note the wiring colors as well. I believe is simply swapped the wiring on the bulbs as this would be the easiest to remove and re-install.

Also... you can use YOUR wiring diagram to ascertain the color are correct. If you don't have one... let me know and I can either tell you the colors for your year or guide you to a diagram.
__________________
My best,


Tony
"Black-Tooth and me since 1983"
  #3  
Old May 6 2012, 10:55 am
catterar's Avatar
catterar catterar is offline
Bob Cattera
 
Join Date: Nov 2009
Location: Angier, NC
Connection Colors Stamped on Light Housing.

On my '81 the wire color is stamped in Italian on the back of the housing at the connector. Bianco = White Nero = Black Rosso = Red etc. When I got mine back from a body shop they had them all messed up. Hope this helps.
__________________
Bob Cattera
'81 X 1/9
Rebuilt at 239,000 miles and
running strong
  #4  
Old May 6 2012, 5:53 pm
jasco's Avatar
jasco jasco is offline
True Classic
 
Join Date: Jul 2009
Location: Sycamore, Il
I just so happened to remove my tail lights today so I can repair the buckets, and your experience led me to take a picture or two. I'm posting them here for all to see and enjoy.



__________________
Come dolce far niente
1982 X 1/9: 1500 FI
Understeer is when you hit the wall with the front and oversteer is when you hit the wall with the back. Horsepower is how fast you hit the wall, torque is how far you take the wall with you.

  #5  
Old May 6 2012, 6:40 pm
EricH's Avatar
EricH EricH is offline
Eric Hamilton
 
Join Date: Jan 2008
Location: Durham NC, USA
Are your license plate lights working properly? How about the side marker lights?

There are three circuits involved here:
- The red wire works the brake lights on both sides.
- A yellow-red wire works the left side marker, the left taillight, and the right(!) license plate light.
- a yellow-black wire works the right side marker, the right taillight, and the left(!) license plate light.

I'm putting my money with Tony's diagnosis; switching the red and the yellow/whatever wire at the taillight assembly is by far the most likely explanation.
__________________
Five '74 X1/9s in various states of drivability
Closed Thread

Thread Tools
Display Modes



INDEX ------------- DF ------------- WF ------------- EF ------------- FSW ------------- Other ------------- Memorials ------------- NFC

Forums IndexDiscussion ForumWorkshop Forum Events ForumFor Sale & Wanted ForumOther Model ForumsMemorials ForumNon-Fiat Content

All times are GMT -7. The time now is 10:28 am.


"Since 1999, the world's largest English language X1/9-specific forum"